Loading...

Knowledge Center


Supported platforms, environments, and operating systems for Security for Microsoft SharePoint (formerly PortalShield)
Technical Articles ID:   KB68141
Last Modified:  5/31/2019
Rated:


Environment

McAfee Security for Microsoft SharePoint (MSMS) 3.5.x, 3.0

Summary

As manufacturers release new operating systems, platforms, and service packs, the original product guides might not reflect the current support policy for those platforms.
 
Most of the following information is available in the product installation guides and readme.txt files. Some of the information is available only in product management statements published in the Knowledge Base.

Recent updates to this article
Date Update
May 31, 2019 Added SharePoint 2019 support information.
January 17, 2019 Added Microsoft Windows Server 2019 Standard support information.
January 10, 2019 Added Microsoft Windows Server 2019 Datacenter support information.
November 13, 2018 Added Product Release Information table.
May 24, 2018 Added the Recent Updates table and collapsible sections.


Product Release Information
 
MSMS Version Release Date Release Notes
3.5.1 November 13, 2018 PD28093
3.5.0 Hotfix 1217273 December 12, 2017 PD28110
3.5.0 July 23, 2015 PD26052
3.0 August 1, 2013 PD24639

The following tables detail the support for MSMS on Windows Server operating systems and other relevant environments. Only the most current versions are included because most customers upgrade to the latest Service Packs shortly after they are released.

Click to expand the section you want to view:

Microsoft Operating System1
Microsoft
Service Pack
MSMS
3.5
MSMS
3.0
Microsoft Windows Server 2019 Standard   Yes No
Microsoft Windows Server 2019 Datacenter   Yes No
Microsoft Windows Server 2016   Yes No
Microsoft Windows Server 2012 R2   Yes Yes
Microsoft Windows Server 2012 N/A Yes Yes
Microsoft Windows 2008   Yes Yes
Microsoft Windows 2008 R2 Standard   Yes Yes
Microsoft Windows 2008 R2 Enterprise   Yes Yes
Microsoft Windows 2008 R2 Datacenter   Yes Yes
Microsoft Windows Web Server 2008 R2   Yes Yes
Microsoft Windows 2003 Standard Edition2  SP1 or above No Yes
Microsoft Windows 2003 Enterprise Edition2  SP1 or above No Yes
Microsoft Windows 2003 Datacenter Edition2  SP1 or above No Yes
Microsoft Windows 2003 Web Edition2  SP1 or above No Yes

All operating systems listed for MSMS 3.0 and 3.5 are supported on x64 versions only.

The MSMS 3.0 Product Guide does not list Windows 2003 x64 SP1 (and above) as supported operating systems. This information is noted in Documentation Correction KB81914. These operating systems are fully supported when running with a supported version of Microsoft SharePoint. See the SharePoint Versions table below.
Microsoft Office SharePoint Server1
Microsoft
Service Pack
MSMS 3.5 MSMS 3.0
SharePoint Server 2019   Yes (Patch1)  
SharePoint Server 2016   Yes (+ HF 1134987)  
SharePoint Server 2013 SP1   Yes Yes
SharePoint Foundation Server 2013   Yes Yes
SharePoint Server 2013   Yes Yes
SharePoint Server 2010 SP2 CU2 Yes Yes
SharePoint Server 2010 SP2 Yes Yes
SharePoint Foundation 2010 SP2 Yes Yes
Windows SharePoint Services 3.0 SP2 Yes Yes
Office SharePoint Server 2007 SP2 Yes2 Yes2
Windows SharePoint Services 2.0 SP3 No No
Office SharePoint 2003 SP3 No No

All SharePoint editions are supported on both x86 and x64 platforms except for SharePoint Server 2010, which is available only in the 64-bit edition.

MSMS 3.5 and 3.0 support only the 64-bit SharePoint Server 2007.
ePolicy Orchestrator
  • ePolicy Orchestrator 5.1.x
  • ePolicy Orchestrator 5.3.x
  • ePolicy Orchestrator 5.9.0 (MSMS35REPORTS 3.5.1511.100, MSMS____3500 3.5.1444.102)
Web Browser
MSMS
3.5
MSMS
3.0
Internet Explorer 11.0 Yes Yes
Internet Explorer 10.0 Yes Yes
Internet Explorer 9.0 Yes Yes
Internet Explorer 8.0 No Yes
Internet Explorer 7.0 No No
Internet Explorer 6.0 SP1 No No
Mozilla Firefox 30.x1 Yes Yes
Mozilla Firefox 31.x1 Yes Yes
Google Chrome 40.x Yes Yes


1 You can use the Mozilla-based standalone user interface for MSMS.
Virtual Platform
MSMS
3.5
MSMS
3.0
VMware ESX 5.x Yes Yes
VMware Workstation 7.0 or later Yes Yes
VMware ESX Server 4.5 Yes Yes
VMware ESX Server 4.0 No No
VMware Server 2.0 No No
Windows Server 2012 Hyper-V Yes Yes
Hyper-V Server 2012 Yes Yes
Hyper-V Server 2012 R2 Yes Yes
Windows Server 2008 R2 Hyper-V Yes Yes
Microsoft Hyper-V Server 2008 R2 Yes Yes
 

Rate this document

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.