Loading...

Knowledge Center


Endpoint Encryption for Files and Folders 4.0 Patch 1 Hotfix 820173
Technical Articles ID:  KB76888
Last Modified:  12/19/2012

Environment

McAfee Endpoint Encryption for Files and Folders (EEFF) 4.0 Patch 1 Hotfix 820173
Microsoft Windows 7 (32-bit/64-bit)
Microsoft Windows XP (32-bit)

Summary

Hotfix 820173 resolves the following issue:

Article
Reference 
Description 
KB76936
820173
When upgrading McAfee Agent on a system installed with EEFF 4.0 Patch 1, the MfeFFCoreservice.exe service crashes on the MfeFFMAProvider.dll module.


NOTES:

  • This hotfix is available from the McAfee download site using a valid grant number.
  • The EEFF 4.0 Patch 1 Hotfix 820173 Release Notes are attached to this article.


FAQs about EEFF 4.0 Patch 1 Hotfix 820173 

What is EEFF 4.0 Patch 1 Hotfix 820173 for?
This hotfix is for a compatibility issue that is seen when McAfee Agent (MA) is upgraded on a system with EEFF 4.0 Patch 1 (4.0.1) installed.
During the MA upgrade process in the presence of EEFF 4.0.1 the following will be reported:

  • On Windows 7 64-bit the EEFF core service crashes, the EEFF service restarts gracefully, and nothing is impacted or seen.
  • On Windows 7 and XP 32-bit systems, Windows shows the end users an error dialog about the crash. On these systems, the EEFF service recovers after the system is rebooted.

However, to prevent help desk support calls and to ensure that the end user impact is minimal, we strongly recommended that customers upgrade from EEFF 4.0.1 to 4.0.1 Hotfix 820173 before upgrading the McAfee Agent.


When should I use Hotfix 820173?
You should use this hotfix if you are on EEFF 4.0.1, and want to upgrade MA either:

  • In preparation for an upgrade to EEFF 4.1
  • For other reasons, for example due to other McAfee product requirements


What are the recommended steps/actions if I satisfy the criteria above?
Use the following procedure:

  1. Upgrade from EEFF 4.0.1 to EEFF 4.0.1 Hotfix 820173.
  2. Upgrade MA only after the EEFF hotfix installation process is complete.
     

What are the supported versions of MA and ePO for EEFF 4.1 ?
For ePO and MA, the supported versions are:

  • MA 4.6 RTW (build 4.6.0.1694 ) or later
  • ePO 4.6 Patch 2 or later
     

I am currently on EEFF 4.0.0; do I need to install this hotfix if I am upgrading to EEFF 4.1?
No. You do not need to install Hotfix 820173.
 

I am currently on EEFF 4.0.0; do I need to install this hotfix if I choose to upgrade the MA?
No. You do not need to install Hotfix 820173.
 

I am currently on EEFF 4.0.0 and I want to upgrade to EEFF 4.0 Patch 1. What do I do in this case?
Upgrade from EEFF 4.0.0 directly to EEFF 4.0.1 Hotfix 820173.
 

I am already on an MA version 4.6 release (for example MA 4.6 Patch 2). I am on EEFF 4.0.1, and want to upgrade to EEFF 4.1. Do I require this hotfix?
If you are on MA 4.6 or a later release, you are already on a supported MA version for EEFF 4.1. For the purpose of upgrading EEFF 4.0.1 to EEFF 4.1, you do not need to upgrade MA in this case, and you do not need this hotfix.


I have now successfully upgraded to EEFF 4.1; do I need to be concerned when I upgrade MA in the future?

No. The issue has been resolved as part of the EEFF 4.1 release. You do not have to be concerned when you upgrade MA in the future.


I am doing a fresh installation of EEFF 4.1 on systems in my environment. Will I be impacted by this issue ?
No. New installations are not impacted by this issue.

Attachment

EEFF_4.0_Patch 1_with_HF820173.zip
6K • < 1 minute @ 56k, < 1 minute @ broadband


Rate this document

Did this article resolve your issue?

Please provide any comments below

Glossary of Technical Terms


Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.
United States - English
© 2003-2013 McAfee, Inc.