Loading...

Knowledge Center


Supported platforms, environments, and operating systems for Management of Native Encryption
Technical Articles ID:   KB79375
Last Modified:  11/12/2019
Rated:


Environment

McAfee Management of Native Encryption (MNE) 5.x, 4.x

Summary

As Apple and Microsoft release new operating systems or service packs, the original McAfee product guides might not reflect the current support policy for those platforms. Most of the following information is available in the Product Guides and Release Notes. But, some of the information is available only in Product Management statements published in the Knowledge Base.

Recent updates to this article:
Date Update
November 12, 2019 Correction implemented for Windows 10 Version 1909:
  • From: October 2019 Update
  • To: November 2019 Update
November 8, 2019 Added support for Windows 10 version 1909 (October 2019 Update).
October 8, 2019 Added MNE 5.0.2 (General Availability) information.
September 24, 2019 Added:
  • MNE 5.0.2 (Released to Support) information
  • macOS Catalina 10.15

To receive email notification when this article is updated, click Subscribe on the right side of the page. You must be logged on to subscribe.


Contents
Click to expand the section you want to view:


MNE is a management product that allows ePolicy Orchestrator (ePO) administrators to manage Apple FileVault and Microsoft BitLocker, the native encryption offerings on OS X (Mac) and Windows systems, respectively. MNE can also help users in system recovery, and provides rich audit and reporting capabilities.

NOTE: See the Related Information section for where to download McAfee products and updates. For hotfixes, see the footnotes.

Product Release information

To review the known issues:  
MNE Version MNE
Mac OS X
Package
Build
MNE
Windows
Package
Build
DEGO for
Mac OS X
Package
Build
Release
Notes
Release
Date
End of Life
Date
MNE 5.0.2 (GA) 5.0.2.109 5.0.1.2 5.0.2.116 Release Notes October 8, 2019 -
MNE 5.0.1 (GA) 5.0.0.3 5.0.1.2 5.0.0.3 Release Notes May 14, 2019 -
MNE 5.0.0 (GA) 5.0.0.3 5.0.0.188 5.0.0.3 Release Notes March 12, 2019  
MNE 4.1.5 (GA) 4.1.5.31 4.1.5.3 4.1.5.31 Release Notes October 9, 2018 -
MNE 4.1.4 (GA) 4.1.4.15 4.1.4.2 4.1.4.15 Release Notes April 10, 2018 -
MNE 4.1.3 (GA) 4.1.3.14 4.1.3.1 4.1.3.14 Release Notes January 9, 2018 -
MNE 4.1.2 (GA)10 4.1.2.41 4.1.2.8 4.1.2.41 Release Notes November 13, 2017 -
MNE 4.1.1 (GA) 4.1.1.363 4.1.1.4 4.1.1.363 Release Notes March 29, 2017 -
MNE 4.1 (reposted) 9 4.1.0.361 4.1.0.29 4.1.0.361 Release Notes September 20, 2016 -
MNE 4.1 (GA) 8 4.0.0.358 4.1.0.29 4.0.0.358 8 Release Notes March 29, 2016 -
MNE 4.0 (GA) 4.0.0.358 4.0.0.84 4.0.0.358 Release Notes December 15, 2015 -
MNE 3.0.1 (GA) 2.1.0.306 4 3.0.1.5 2.1.0.306 4 Release Notes July 27, 2015 December 15, 2018
MNE 3.0 (GA) 2.1.0.306 4 3.0.0.48 2.1.0.306 4 Release Notes April 15, 2015
MNE 2.1.1 (GA) 7 2.1.1.355 - 2.1.1.355 EOL September 21, 2015 April 29, 2017
 
MNE 2.1.0 Hotfix 1072394 (GA) 6 2.1.0.336 - - EOL June 22, 2015
MNE 2.1.0 Hotfix 1061758 (RTS) 5 2.1.0.335 - - EOL May 12, 2015
MNE 2.1 (GA) 2.1.0.306 2.1.0.132 2.1.0.306 EOL December 9, 2014
MNE 2.0.1 (GA) 1 2.0.1.293 2.0.0.325 - EOL October 15, 2014 December 31, 2016
 
MNE 2.0 (GA) 2
2.0.0.269 2.0.0.325 - EOL July 30, 2014
MNE 1.0 (GA) 3
1.0.0 - - EOL October 31, 2013

RTS = Released to Support
GA = General Availability
 
1 MNE 2.0.1 added support for Apple FileVault on OS X 10.10 (Yosemite).
2 MNE 2.0 provides management of Apple FileVault and Microsoft BitLocker.
3 MNE 1.0 provided management of Apple FileVault only. (EOL - March 31, 2016)
4 The MNE OS X client packages have not been updated in this release. So, the MNE 3.0.x release package includes the Mac OS X 2.1.0 client and Drive Encryption GO (DEGO) software packages.
5 MNE 2.1.0 Hotfix 1072394 supersedes MNE 2.1.0 Hotfix 1061758
6 MNE 2.1.0 Hotfix 1072394 is a Mac OS X only release used for the management of FileVault. This hotfix is available on the Product Downloads site.
7 MNE 2.1.1 is a Mac OS X release:
  • This release includes the fixes for issues addressed in MNE 2.1.0 Hotfix 1072394.
  • Adds support for Apple FileVault on OS X 10.11 (El Capitan).
  • MNE 2.1.1 Mac client is compatible with MNE 2.1 and MNE 3.0.x extensions.
8 The MNE OS X client packages have not been updated in this release. So, the MNE 4.1.0 release package includes the Mac OS X 4.0.0 client and DEGO software packages.
9 This release package now includes the Mac OS X 4.1.0 client and DEGO software packages to support Mac OS X Sierra 10.12.0. The Windows client packages have not been updated in this release.
10 The MNE 4.1.2 package at the download site has the build number 4.1.2.9.


Extensions Information
 
MNE Version
MNE Admin
Extension
MNE
Advanced
Features
Extension 4
MNE Help
Extension
DPSSP 1
Extension
DEGO 3
Extension
Maintenance
Mode Tool
4
MNE 5.0.2
MNE 5.0.1
5.0.1.2 - 5.0.0.011 1.3.2.7 7.2.8.4 1.1.0.11
MNE 5.0.0 5.0.0.111 - 5.0.0.011 1.3.2.7 7.2.8.4 1.1.0.11
MNE 4.1.5 4.1.5.11 1.0.0.11 4.1.2.030 1.3.2.7 7.2.7.7 1.1.0.9
MNE 4.1.4 4.1.4.12 1.0.0.11 4.1.2.030 1.3.2.7 7.2.5.24 1.1.0.9
MNE 4.1.3 4.1.3.6 1.0.0.11 4.1.2.030 1.3.1.1 7.2.3.29 1.1.0.9
MNE 4.1.2 4.1.2.11 1.0.0.11 4.1.2.030 1.3.1.1 7.2.2.14 1.1.0.9
MNE 4.1.1 4.1.1.5 1.0.0.9 4.1.0.030 1.3.0.12 7.2.1.24 1.1.0.5
MNE 4.1.0 4.1.0.37 1.0.0.9 4.1.0.030 1.3.0.6 7.1.3.547 1.1.0.5
MNE 4.0.0 4.0.0.206 1.0.0.8 4.0.0.030 1.2.0.9 7.1.3.547 1.1.0.5
MNE 3.0.1 3.0.1.7 - 3.0.0.010 1.2.0.3 7.1.3.547 1.1.0.2
MNE 3.0.0 3.0.0.92 - 3.0.0.010 1.2.0.3 7.1.2.494 1.1.0.2
MNE 2.1.1 3.0.1.7 - 3.0.0.010 1.2.0.3 7.1.3.547 -
MNE 2.1.0 2.1.0.99 - 2.1.0.010 1.1.0.37 7.1.2.494 -
MNE 2.0.0 2.0.0.302 - 2.0.0.040 2 1.0.1.20 - -
MNE 1.0.0
1.0.0.81 - 100.06 - - -
 
The Data Protection Self Service Portal (DPSSP) extension is included in the MNE package for convenience. But, it is developed as a separate component, so it has its own version number.
2 When upgrading, you must remove the existing MNE 1.0 help extension before checking in the MNE 2.0 help extension. If you fail to do so, you incur the error described in KB82509.
3 The DEGO extension is included in the MNE package because the DEGO for Mac OS X client package requires it. But, it is developed and also distributed as part of the Drive Encryption product, as reflected in the version number.
4 MNE adopts a component-based development approach, where each major component has its own separate version number. As a result, components such as the Advanced Features extension introduced in MNE 4.0 has a version number that might differ from the main product version. The Advanced Features functionality was merged into the MNE Admin extension as of MNE 5.0.0.


Back to top


NOTE: If the operating system is not listed, it is not supported.

Windows operating systems
 
Windows Microsoft
Supported
Service Pack
MNE
5.0.0
5.0.1
5.0.2
MNE
4.1.5
MNE
4.1.3
4.1.4
MNE
4.1.2
MNE
4.0.x
4.1.0

Server
Windows Server 2019 (all editions)   Yes Yes Yes Yes No
Windows Server 2016 (all editions) - Yes Yes Yes Yes Yes
Windows Server 2012 R2 (all editions) - Yes Yes Yes Yes Yes
Windows Server 2012 (all editions) - Yes Yes Yes Yes Yes
Windows Server 2008 R2 (x86 processors only)
(all editions)
NOTE: Itanium processors are not supported.
- Yes Yes Yes Yes Yes

Client
Windows 10 version 1909 (November, 2019 Update)
Windows 10 version 1903 (May 2019 Update)
(32-bit and 64-bit) (Editions: Pro, Enterprise)
  Yes Yes No No No
Windows 10 version 1809 LTSC (October 2018 update) 3 
32-bit and 64-bit) (Enterprise)
  Yes Yes Yes No No
Windows 10 version 1809 (October 2018 Update)
(32-bit and 64-bit) (Editions: Pro, Enterprise)
  Yes Yes Yes No No
Windows 10 version 1803 (April 2018 Update) 
(32-bit and 64-bit) (Editions: Pro, Enterprise)
  Yes Yes Yes No No
Windows 10 version 1709 (Fall Creators Update) 4
(32-bit and 64-bit) (Editions: Pro, Enterprise)
- Yes Yes Yes Yes No
Windows 10 version 1703 (Creators Update) 4
(32-bit and 64-bit) (Editions: Pro, Enterprise)
- Yes Yes Yes Yes No
Windows 10 version 1607 LTSB (Anniversary Update) 3
(32-bit and 64-bit)(Enterprise)
  Yes Yes Yes Yes No
Windows 10 version 1607 (Anniversary Update)
(32-bit and 64-bit) (Editions: Pro, Enterprise)
  Yes Yes Yes Yes No
Windows 10 version 1507 (General Availability) 2
(32-bit and 64-bit), (Editions: Pro, Enterprise)
- Yes Yes Yes Yes Yes
 
Windows 8.1, including updates (32-bit and 64-bit)
(Editions: Enterprise, Professional)
- Yes Yes Yes Yes Yes
Windows 8.0 (32-bit and 64-bit)
(Editions: Enterprise, Professional)
- Yes Yes Yes Yes Yes
 
Windows 7.0 (32-bit and 64-bit)
(Editions: Enterprise, Ultimate)
SP1 Yes Yes Yes Yes Yes
Windows 10 To Go (64-bit) 1, 5 - Yes Yes Yes Yes Yes
Windows 8.x To Go (32-bit and 64-bit) 1, 5 - Yes Yes Yes Yes Yes
 
See KB82249 for further information about support for Windows To Go.
2 Includes support for Microsoft Windows 10 version 1511 and Windows 10 Anniversary Update. To review Windows 10 compatibility with McAfee products, see KB85784.
3
Windows 10 Enterprise Long Term Servicing Channel (LTSC) or Long-Term Servicing Branch (LTSB), is only supported with MNE 4.1.1 and later.
NOTES:
4 MNE 4.1.1 is the minimum supported version of Management of Native Encryption for Windows 10 Creators Update and Windows 10 Fall Creators Update.
5 MNE does not currently support Microsoft BitLocker To Go (BitLocker encryption for USB drives). For details, see KB87806.
6 This release supports Windows 10 Spring Creators Update 2018 (version 1803).


Supported macOS X operating systems
 
macOS MNE
5.0.2
MNE
4.1.5

5.0.0
5.0.1
MNE
4.1.3
4.1.4

 
MNE
4.1.2
MNE
4.1.0

4.1.1
MNE
4.0.0
Catalina 10.15 Yes No No No No No
Mojave 10.14 1 Yes Yes No No No No
High Sierra 10.13.2 and later No Yes Yes No No No
High Sierra 10.13.010.13.1 No Yes Yes Yes No No
Sierra 10.12.x No Yes Yes Yes Yes No
El Capitan 10.11.x No No Yes Yes Yes Yes
Yosemite 10.10.x No No Yes Yes Yes Yes
Mavericks 10.9.x No No No No Yes Yes
Mountain Lion 10.8.2 and later No No No No No Yes
 
1 Minimum version to use with macOS 10.14.x (Mojave), is MA 5.5.1 Hotfix 1248290. To view macOS compatibility with other McAfee products, see KB90888.

Back to top


Supported ePO versions

NOTE:  ePO 5.10.0 applies to both ePO on-premises and McAfee ePO on Amazon Web Services (ePO on AWS).
 
ePO
Version MNE
4.1.4
4.1.5

5.0.0
5.0.1
5.0.2
MNE
4.1.1
4.1.2
4.1.3
MNE
4.1.0
MNE
4.0.0
ePO 5.10.0 Yes No No No
ePO 5.9.1, 5.9.0 Yes Yes No No
ePO 5.3.3 Yes Yes Yes No
ePO 5.3.2 Yes Yes Yes Yes
ePO 5.3.1, 5.3.0 Yes Yes Yes Yes
ePO 5.1.3, 5.1.2 No Yes Yes Yes
ePO 5.1.1, 5.1.0 No Yes Yes Yes


Supported McAfee Agent versions

MA – Windows clients
Version MNE
4.1.5
5.0.0
5.0.1
​5.0.2
MNE
4.1.2
4.1.3

4.1.4
MNE
4.0.0
4.1.0
4.1.1
MA 5.6.0 - 5.6.2 1 Yes No No
MA 5.5.2, 5.5.1, 5.5.0 Yes Yes No
MA 5.0.6, 5.0.5 Yes Yes Yes
MA 5.0.3, 5.0.4 Yes Yes Yes
MA 5.0.1, 5.0.2 Yes Yes Yes
MA 5.0.0 Yes Yes Yes
MA 4.8.x (GA) 2 No No No
 
1 MA 5.6.0 is the minimum supported version for customers intending to use the McAfee Preboot with Data Exchange layer (DXL) Provisioning introduced with MNE 5.0.0 
2 MA 4.8.x has reached End of Life and is no longer supported.

MA - macOS clients
Version MNE
4.1.5

5.0.0
5.0.1
​5.0.2
MNE
4.1.3
4.1.4
MNE
4.1.2
MNE
4.0.0
4.1.0

4.1.1
MA 5.6.2 5
MA 5.6.0, 5.6.1
Yes Yes Yes No
MA 5.5.2 Yes Yes Yes No
MA 5.5.1 Hotfix 1248290 (build 5.5.1.374) Yes Yes Yes No
MA 5.5.0, 5.5.1 No Yes Yes No
MA 5.0.6 3 No Yes Yes Yes
MA 5.0.5 No Yes Yes Yes
MA 5.0.3, 5.0.4 No Yes Yes Yes
MA 5.0.2 2 No Yes Yes Yes
MA 5.0.1 1 No Yes Yes Yes
MA 5.0.0 No No No No
MA 4.8.x 4 No No No No
 
IMPORTANT: With McAfee Agent 5.0 and later, support is provided only for OS X 10.10 (Yosemite) with MNE 2.0.1 and later releases.
2 Recommended minimum versions to use with OS X 10.10.x (Yosemite) and 10.11.x (El Capitan).
3 Recommended minimum version to use with macOS High Sierra (10.13.x) is MA 5.0.6 Hotfix 1211288 (HF1211288)
4 MA 4.8.x has reached End of Life and is no longer supported.
6 Minimum supported version to use with macOS Catalina 10.15.x.


IMPORTANT: McAfee recommends that you do not use DPSSP on public computers, and close the browser after recovery.
Browser
Google Chrome
Internet Explorer
Mozilla Firefox
Safari 1
 
Take care when using Safari because of the non-standard behavior of its page caching.


Supported Languages for McAfee Preboot (MNE 5.0 and later)
English

Supported languages for MNE in ePO
English
French
German
Japanese
Spanish

Supported languages for DPSSP in ePO
Language DPSSP
1.3
DPSSP
1.2, 1.1, 1.0
Brazilian (Portuguese Yes No
Chinese (Simplified) Yes No
Chinese (Traditional) Yes No
Danish Yes No
Dutch Yes No
English Yes Yes
French Yes Yes
Finnish Yes No
German Yes Yes
Japanese Yes Yes
Korean Yes No
Norwegian Yes No
Portuguese Yes No
Russian Yes No
Spanish Yes Yes
Swedish Yes No
Turkish Yes No

Supported languages for Mac OS X
Language Mac OS X
ePO Package
(Client)
  Mac OS X
Standalone Package
(Client)
MNE
4.x
5.0.x
5.1.x
MNE
4.x
5.0.x
5.1.x
Brazilian (Portuguese) No No
Chinese (Simplified) No No
Chinese (Traditional) No No
Czech No No
Danish No No
Dutch No No
English Yes Yes
Finnish No No
French Yes Yes
German Yes Yes
Greek No No
Hungarian No No
Italian No No
Japanese Yes Yes
Korean No No
Norwegian No No
Polish No No
Portuguese No No
Russian No No
Slovak No No
Slovenian No No
Spanish Yes Yes
Swedish No No
Turkish No No

Supported languages for Windows
Language Windows
ePO Package
(Extensions)


MNE
  Windows
ePO Package
(Client)


MNE
  Windows
Standalone
Package
(Client)

MNE
4.0.x
4.1.x
5.0.x
5.1.x
4.0.x
4.1.x
5.0.x
5.1.x
4.0.x
4.1.x
5.0.x
5.1.x
Brazilian (Portuguese) No Yes No
Chinese (Simplified) No Yes Yes
Chinese (Traditional) No Yes Yes
Czech No Yes No
Danish No Yes No
Dutch No Yes No
English Yes Yes Yes
Finnish No Yes No
French Yes Yes Yes
German Yes Yes Yes
Greek No Yes No
Hungarian No Yes No
Italian No Yes No
Japanese Yes Yes Yes
Korean No Yes Yes
Norwegian No Yes No
Polish No Yes No
Portuguese No Yes No
Russian No Yes No
Slovak No Yes No
Slovenian No Yes No
Spanish Yes Yes Yes
Swedish No Yes No
Turkish No Yes No

Documentation localization
The Product Guide, Reference Guide, and Installation Guide are available only in the following languages:
 
English
French
German
Japanese
Spanish


The Release Notes are available only in the following languages:
 
English
Chinese (Simplified)
Chinese (Traditional)
French
German
Japanese
Korean
Spanish
Italian 1
Portuguese-Brazilian 1

1 Release Notes are provided in other languages as of MNE 4.0.

NOTE: Product documentation is available at docs.mcafee.com.

Back to top



System Requirements
 
Systems Requirements
Client Systems for MNE CPU: Works on all Intel®-based systems
RAM: 1 GB minimum
Hard Disk: 1-GB minimum free disk space

Software Requirements
 
Software Requirements
Microsoft Windows Installer 3.0 Redistributable package (for McAfee ePO) See the product documentation for your version of McAfee ePO.
See the product documentation for your version of McAfee ePO. Microsoft .NET Framework 2.0 Redistributable package (for McAfee ePO)
Microsoft MSXML 6 (for McAfee ePO) See the product documentation for your version of McAfee ePO.

Rate this document

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.