Loading...

Knowledge Center


Unable to install extension. java.sql.SQLException: Incorrect syntax near 'MERGE' (Endpoint Security Migration Extension installation failure)
Technical Articles ID:   KB86470
Last Modified:  8/9/2018
Rated:


Environment

McAfee Endpoint Security (ENS) 10.x

Microsoft Windows Server 2012, 2008

Problem

The Endpoint Security Migration Extension fails to install and the following error message displays:
 
Error : Unable to install extension. java.sql.SQLException: Incorrect syntax near 'MERGE'. You may need to set the compatibility level of the current database to a higher value to enable this feature. See help for the SET COMPATIBILITY_LEVEL option of ALTER DATABASE.

Solution

Install the Endpoint Security Migration Extension in ePolicy Orchestrator (ePO), by changing the Compatibility Level of the current database:
  1. Go to the SQL Server where the ePO database is hosted.
  2. Open Microsoft SQL Server Management Studio.
  3. Expand Databases.
  4. Right-click the ePO database (where the default name is ePO_<ePO_server_name>), and select Properties.
  5. Select Options. The Compatibility Level is on the right.
  6. Set the Compatibility Level to SQL Server 2008 (100).
  7. Click OK.
  8. Close Microsoft SQL Server Management Studio.

Rate this document

Beta Translate with

Select a desired language below to translate this page.

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.