Loading...

Knowledge Center


Important prerequisites for installing VirusScan Enterprise for Storage 1.2.0
Technical Articles ID:   KB86868
Last Modified:  4/7/2017
Rated:


Environment

McAfee VirusScan Enterprise for Storage (VSES) 1.2.0

For details of VSES supported environments, see KB74863.

Summary

IMPORTANT: This article describes the prerequisites and requirements for successfully installing or upgrading to VSES 1.2.0. It is vital that you follow these steps exactly to ensure your installation or upgrade is successful.

VSES 1.2.0 Requirements
VSES 1.2.0 requires the use of Syscore 15.4.0.811 or later. McAfee Agent (MA) and VirusScan Enterprise (VSE) products that are compatible with Syscore 15.4.0.811:

NOTE: No earlier versions of MA or VSE are compatible with VSES 1.2.0.
  • MA 4.8.0.1500 (MA 4.8 Patch 2) or later

    NOTE: MA 4.8.x does not use Syscore; it is always compatible.
     
  • MA 5.0.2.333 (MA 5.0.2 Hotfix 1110392) or later
  • VSE 8.8.0.1528 (VSE 8.8 Patch 7) or later
VSES 1.2.0 also requires the use of VSE 8.8.0.1528 (VSE 8.8 Patch 7) or later for reasons beyond Syscore. 

IMPORTANT: VSE 8.8.0.1385 (Patch 5) and later completely replace the underlying internal security mechanisms used by McAfee endpoint products. See KB70393 for information on known issues that must be verified or resolved before you install these VSE builds. Failure to verify and resolve these known issues may result in unbootable computers or damaged installations of McAfee endpoint products. It is strongly recommended that you review any applicable Known Issues articles for other McAfee endpoint products in your environment to ensure that they are compatible with VSE 8.8.0.1528 (Patch 7) and Syscore 15.4.

Fresh Installation Procedure
To install VSES 1.2.0 on a new scanner:
  1.  Install MA. Install only one of the following versions:
    • For MA 4.8.x:  MA 4.8.0.1500 (MA 4.8 Patch 2) or later
    • For MA 5.0.x:  MA 5.0.2.333 (MA 5.0 Hotfix 1110392) or later 
       
  2. Install VSE 8.8.0.1528 (VSE 8.8 Patch 7) or later.
  3. If VSE 8.8.0.1528 (Patch 7) is installed in the previous step, install VSE 8.8 Hotfix 1123565.

    NOTE: This hotfix is available from the ServicePortal. For Details see the Related Information section.
     
  4. Install VSES 1.2.0.

    NOTE: For correct operation of the VSES 1.2.0 module in NetApp CDOT deployments, VSES 1.2.0 Hotfix 1135217 is required. This hotfix is available from the ServicePortal. For details see the Related Information section.
     
  5. Reboot the system.

Upgrade Installation Requirements
You can upgrade directly to VSES 1.2.0 from the following earlier VSES versions:
  • 1.0.2
  • 1.0.3
  • 1.1.0
These earlier VSES versions are not compatible with MA 5.x; therefore, any VSES scanners to be upgraded must be currently running MA 4.8.x.

IMPORTANT:
  • If the version of MA 4.8.x currently running on the scanners is not MA 4.8.0.1500 (MA 4.8 Patch 2) or later, install a compatible version of MA 4.8.x before you execute the VSE and VSES upgrade procedures.
  • If MA 5.x is to be installed on the VSES scanners, it must be installed after the VSE and VSES upgrade procedures and must be MA 5.0.2.333 (MA 5.0 Hotfix 1110392) or later.

Upgrade Installation Procedure
On existing VSES scanners, ensure that MA 4.8.0.1500 (MA 4.8 Patch 2) or later is installed.
  1. On the ePolicy Orchestrator (ePO) server, log on to the ePO console and perform the following actions:
    1.   Back up existing VSE policies.
    2.   Back up existing VSES policies.
    3.   Upgrade the VSE Management extension to 8.8.0.448 or later.
    4.   Upgrade the VSE Reporting extension to 1.2.0.272 or later.
    5.   Install the VSES extension, version 1.2.0.109. 
        
  2. On the ePO server, in File Explorer, extract epopolicymigration.exe from the VSES 1.2.0 archive.
  3. On the ePO server, in a user account control-elevated cmd.exe prompt:
    1. Navigate to the folder where you extracted epopolicymigration.exe.
    2. Execute epopolicymigration.exe using the appropriate option:
      • For Windows authentication to the ePO database, execute:  ePOPolicyMigration.exe /VSES
      • For SQL authentication to the ePO database, execute:  ePOPolicyMigration.exe /VSES /PASSWORD="<your SQL password>"

        NOTE: When the ePO database was initially installed, either Windows authentication or SQL authentication was selected. That selection determines the method to use with ePOPolicyMigration.exe.
         
  4. On the ePO server, in the ePO console, verify that VSES policies were successfully migrated by viewing the VSES 1.2.0 policies.
  5. In the storage appliance administration interface, remove VSES scanners that will be upgraded to VSES 1.2.0 from the active scanners list.

    IMPORTANT: If you do not perform this step, unexpected outages and disconnects between the storage appliances and the scanner will occur during the upgrade procedures.
     
  6. In the ePO console or on the VSES scanners:
    1. Upgrade VSE to 8.8.0.1528 or later.
    2. Verify that VSE 8.8.0.1528 or later is installed.
    3. If VSE 8.8.0.1528 (Patch 7) is installed in the previous step, install VSE 8.8 Hotfix 1123565.
    4. Upgrade VSES to 1.2.0.
    5. Verify that VSES 1.2.0 is installed.
       
  7. Reboot the scanner.
  8. After the reboot completes, on the ePO server, in the ePO console, propagate the VSE 8.8 and VSES 1.2.0 policies from the new extensions to the scanner.
  9. On the scanner, in the VSE console:
    1. Verify that VSE 8.8 policies have propagated.
    2. Verify that VSES 1.2.0 policies have propagated.
       
  10. In the storage appliance administration interface, add VSES scanners that have been upgraded to the active scanners list.

Rate this document

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.