Loading...

Knowledge Center


How to determine product version information for Endpoint Security for Linux Threat Prevention
Technical Articles ID:   KB89715
Last Modified:  8/24/2017
Rated:


Environment

McAfee Endpoint Security for Linux Threat Prevention (ENSLTP) 10.2.x

For details of ENSLTP supported environments, see KB87073.

Summary

This article describes how to determine the product/patch/hotfix version, DAT version, Scan Engine version, and build numbers for ENSLTP. Knowing the ENSLTP version information is essential when troubleshooting issues. This article explains two methods to check the version information on the local system.


Method 1 - Use the isecav command
The ENSLTP isecav command shows the version information as shown in the following example:
 
# /opt/isec/ens/threatprevention/bin/isecav --version
McAfee Endpoint Security for Linux Threat Prevention
Version : 10.2.1.887
Patch Version : 1
HF Version : 1195156

License : Full
DAT Version : 8622.0
Engine Version : 5900.7806

 
Copyright (c) 2017 McAfee, Inc. All rights reserved.
#

In this example, the ENSLTP version is 10.2.1.887 Patch 1 Hotfix 1195156, the DAT version is 8622, and the Scan Engine version is 5900.

You can also check the installed package versions using the package management command for your distribution. The version of the package file name that includes ISecTP should match the ENSLTP version shown in the isecav command.
  • RPM-based system:

     # rpm -qa | grep -i isec
    ISecTP-10.2.1-887.x86_64
    ISecRt-10.2.1-611.x86_64
    ISecESP-10.2.1-882.x86_64
    ISecESPFileAccess-10.2.1-882.x86_64
     
  • Ubuntu system:

    # dpkg --list  | grep -i isec
    ii  isecesp                      10.2.1-882                  amd64        McAfee Endpoint Security Platform for Linux
    ii  isecespfileaccess            10.2.1-882                  amd64        McAfee Endpoint Security File Access
    ii  isecrt                       10.2.1-611                  amd64        McAfee Runtime for Linux
    ii  isectp                       10.2.1-887                  amd64        McAfee Endpoint Security for Linux Threat Prevention

Method 2 - Refer to the prefs.xml file
The ENSLTP version information is kept in the file /opt/isec/ens/threatprevention/var/prefs.xml. View this file using a file editor or using basic operating system commands such as cat and more.

Example:

    <DNDProductInformation type="54">
        <ProductBinDir>bin</ProductBinDir>
        <ProductCLIName>isecav</ProductCLIName>
        <ProductCopyright>Copyright (c) 2017 McAfee, Inc. All rights reserved.</ProductCopyright>
        <ProductInstallDir>/opt/isec/ens/threatprevention</ProductInstallDir>
        <ProductName>McAfee Endpoint Security for Linux Threat Prevention</ProductName>
        <ProductODSReportDir>odsreport</ProductODSReportDir>
        <ProductVarDir>var</ProductVarDir>
        <ProductVersion>10.2.1.887</ProductVersion>
        <VendorName>Intel Security</VendorName>
        <HotFixes>
            <HotFix>1195156</HotFix>
        </HotFixes>
        <Patch>1</Patch>
        <ProductNameForEvent>McAfee Endpoint Security</ProductNameForEvent>
    </DNDProductInformation>
 
    <DNDGlobalSettings type="52">
        <ExtraDATVirusCount>0</ExtraDATVirusCount>
        <ExtraDATVirusList delimiter=",">
            <VirusName/>
        </ExtraDATVirusList>
        <LastUpdatedTimeStamp/>
        <LicenseStatus>3</LicenseStatus>
        <MajorDATVersion>8627</MajorDATVersion>
        <ExtraDATVersion>0</ExtraDATVersion>
        <MajorEngineVersion>5900</MajorEngineVersion>
 
In this example, the ENSLTP version is 10.2.1.887 Patch 1 Hotfix 1195156, the DAT version is 8627, and the Scan Engine version is 5900.
 

Rate this document

Languages:

This article is available in the following languages:

English United States
Japanese

Beta Translate with

Select a desired language below to translate this page.

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.