Loading...

Knowledge Center


Supported platforms, environments, and operating systems for Data Exchange Layer
Technical Articles ID:   KB90421
Last Modified:  9/10/2019

Environment

McAfee Data Exchange Layer (DXL) 5.x, 4.x, 3.x, 2.x

Summary

Recent updates to this article
Date Update
September 10, 2019 Added:
  • DXL 5.0.2 (General Availability release).
  • DXL 4.0.0 Hotfix 10 (Release To Support).
  • DXL 4.1.2 Hotfix 4 (Release To Support).
June 13, 2019 Updated the note added under "Apple supported operating systems with the DXL client" and "Linux supported operating systems with the DXL client" sections for clarity.
June 11, 2019 Added a note under "Apple supported operating systems with the DXL client"  and "Linux supported operating systems with the DXL client" sections.
May 22, 2019 Added a note under "Microsoft Windows supported operating systems with the DXL client" section.
May 21, 2019 Added the DXL 5.0.1 version to the "Supported ePolicy Orchestrator Server Versions" section.

To receive email notification when this article is updated, click Subscribe on the right side of the page. You must be logged on to subscribe.


The following tables describe the supported platforms, environments, and operating systems for DXL.

For the supported platforms, environments, and operating systems for Threat Intelligence Exchange, see KB83368.

Contents
Click to expand the section you want to view:


To view the known and resolved issues for:
Product Version Build Release
Notes
Release Date End of Life
Date
(EOL)
DXL 5.0.2 (GA) 5.0.2.130.7 PD28404 September 10, 2019 -
         
DXL 5.0.1 Hotfix 3 (GA) 5.0.1.223.1 PD28344 May 7, 2019 -
DXL 5.0.1 Hotfix 2 (GA) 5.0.1.218.1 PD28306 April 9, 2019 -
DXL 5.0.1 Hotfix 1 (RTS) 4 5.0.1.212.1 - March 12, 2019 -
DXL 5.0.1 (Server) (GA) 5.0.1.198.1 PD28174 February 26, 2019 -
DXL 5.0.0 Hotfix 1 (Server) (RTS) 4 5.0.0.587.3 - December 17, 2018 -
DXL 5.0.0 (Server) (GA) 2 5.0.5.546.1 PD28080 November 13, 2018 -
         
DXL 4.1.2 Hotfix 4 (RTS) 4 4.1.2.139.1 - September 10, 2019 -
DXL 4.1.2 Hotfix 3 (GA) 4.1.2.123.1 PD28305 April 9, 2019 -
DXL 4.1.2 Hotfix 2 (RTS) 4 4.1.2.118.1 - March 12, 2019 -
DXL 4.1.2 Hotfix 1 (GA) 4.1.2.115.8 PD28173 January 23, 2019  
DXL 4.1.2 (GA) 4.1.2.107.1 PD28067 November 13, 2018 -
DXL 4.1.1 (Repost) 4.1.1.123.30 PD27889 September 11, 2018 -
DXL 4.1.1 (GA) 1 4.1.1.113.3 August 7, 2018 -
DXL 4.1.0 (GA) 4.1.0.184.1 PD27560 - -
         
DXL 4.0.0 Hotfix 10 (RTS) 4 4.0.0.483.1 - September 10, 2019 -
DXL 4.0.0 Hotfix 9 (GA) 4.0.0.471.1 PD28307 May 7, 2019 -
DXL 4.0.0 (GA) 4.0.0.416.1 PD27304 - -
 
DXL 3.1.0 (GA) 3.1.0.580.1 PD26985 - April 10, 2019 3
DXL 3.0.1 (GA) 3.0.1.164.1 EOL October 16, 2018 3
DXL 3.0 (GA) 3.0.0.285.1 EOL
 
DXL 2.2.0 (GA) 2.2.0.205.1 EOL - October 16, 2018 3
DXL 2.0.1 (GA) 2.0.1.140.1 EOL
DXL 2.0 (GA) 2.0.0.409.2 EOL
1 DXL 4.1.1 was reposted to the Product Downloads site because of a SysCore issue documented in KB90301.
2 The DXL 5.0.0 client is now integrated with MA 5.6.0, and is no longer a standalone component deployed by DXL.
McAfee Agent 5.6.0 bundles the McAfee Data Exchange Layer client as a component. The DXL client is now automatically installed on managed systems with McAfee Agent 5.6.0 and automatically connects to a DXL broker in your environment.
3 EOL:
  • DXL 2.x and 3.0.x reach EOL on October 16, 2018. See KB89882 for details.
    • DXL 3.1.x reached EOL on April 10, 2019. See KB90487 for details.
4
McAfee investigated this issue and a solution is currently available. This solution is currently not generally available, but is in Released to Support (RTS) status. To obtain the RTS build, log on to the ServicePortal and create a Service Request (https://support.mcafee.com/ServicePortal/faces/serviceRequests/createSR). Include this article number in the Problem Description field.

See KB51560 for detailed information on release cycles.

NOTE: Starting with DXL 5.0.x, the DXL client is bundled with McAfee Agent. Thus, the McAfee Agent version determines the supported Windows operating system versions. For supported operating system versions for McAfee Agent, see KB51573.
 
Microsoft Windows Server supported operating systems with the DXL client
Operating System DXL
4.1.1
4.1.2
DXL
4.0.0
4.1.0
DXL
3.1.0
1
Windows Server 2019 (64-bit only)
(Standard, Datacenter, Essentials, Core)
Yes No No
Windows Server 2016 RS3 (64-bit only)
(Standard, Datacenter, Essentials, Core)
Yes Yes Yes
Windows Server 2016 (64-bit only)
(Standard, Datacenter, Essentials, Core)
Yes Yes Yes 2
Windows Server 2012 R2 (64-bit only)
(Standard, Datacenter, Essentials, Foundation, Core)
Yes Yes Yes
Windows Server 2012 (64-bit only)
(Standard, Datacenter, Essentials, Foundation, Core)
Yes Yes Yes
Windows Server 2012      
Windows Small Business Server 2011 Yes Yes Yes
Windows Server 2008 R2 (32-bit and 64-bit) Yes Yes Yes
Windows Server 2008 (32-bit and 64-bit) Yes Yes Yes
1 DXL 3.1.x reaches EOL on April 10, 2019. See KB90487 for details.
2 DXL 3.1.0.624.4 (DXL 3.1.0 with Hotfix 11) supports Windows Server 2016 Core RS3.
3 Requires Windows Server 2008 Service Pack 2
  
Microsoft Windows Workstation supported operating systems with the DXL client
Operating System DXL
4.1.2
DXL
4.1.1
DXL
4.1.0
DXL
4.0.0
DXL
3.1.0
1
Windows 10 Version 1809
(October 2018 Update)
Yes No No Yes2 No
Windows 10 Version 1803
(April 2018 Update)
Yes Yes Yes No No
Windows 10 Version 1709
(Fall Creators Update)
Yes Yes Yes Yes No
Windows 10 Version 1703
(Creators Update)
Yes Yes Yes Yes Yes
Windows 10 Version 1607
(Anniversary Update)
Yes Yes Yes Yes Yes
Windows 10 Version 1511
(November Update)
Yes Yes Yes Yes Yes
Windows 10 IoT Enterprise 2015 LTSB No No No No No
Windows 10 Version 1507 Yes Yes Yes Yes Yes
Windows 8.1U1/U2 (32-bit and 64-bit) Yes Yes Yes Yes Yes
Windows 8.1 (32-bit and 64-bit) Yes Yes Yes Yes Yes
Windows 8.0 (32-bit and 64-bit) Yes Yes Yes Yes Yes
Windows Embedded 8 No No No No Yes
Windows 7 (32-bit and 64-bit) Yes Yes Yes Yes Yes
Windows Embedded 7 Yes Yes Yes Yes Yes
1 DXL 3.1.x reaches EOL on April 10, 2019. See KB90487 for details.
2 Support for Windows 10 Version 1809 (October 2018 Update) is introduced in DXL 4.0.0 Hotfix 8. 

NOTE: Starting with DXL 5.0.x, the DXL client is bundled with McAfee Agent. Thus, the McAfee Agent version determines the supported Apple operating system versions. For supported operating system versions for McAfee Agent, see KB51573.
 
Apple supported operating systems with the DXL client
Operating System DXL 2
4.1.1 4.1.2
DXL 2
4.0.0
4.1.0
DXL 1, 2
3.1.0
macOS 10.14 (Mojave) (64-bit only) Yes 3 Yes Yes
macOS 10.13 (High Sierra) (32-bit and 64-bit) Yes Yes Yes
macOS 10.12 (Sierra) (32-bit and 64-bit) Yes Yes Yes
 
OS X 10.11 (El Capitan) (32-bit and 64-bit) Yes Yes Yes
OS X 10.10 (Yosemite) (32-bit and 64-bit) Yes Yes Yes
OS X 10.9 (Mavericks) (32-bit and 64-bit) No Yes Yes
OS X 10.8 (Mountain Lion) (32-bit and 64-bit) No Yes Yes
OS X 10.7 (Lion) (32-bit and 64-bit) No Yes Yes
1 DXL 3.1.x reaches EOL on April 10, 2019. See KB90487 for details.
2 Requires McAfee Agent 5.0.5 or later.
3 Support on macOS, 64-bit only. For macOS compatibility with McAfee products, see KB90888.
 


NOTE: Starting with DXL 5.0.x, the DXL client is bundled with McAfee Agent. Thus, the McAfee Agent version determines the supported Linux operating system versions. For supported operating system versions for McAfee Agent, see KB51573.
 
Linux supported operating systems with the DXL client
Operating System DXL
4.1.1
4.1.2
DXL
4.0.0
4.1.0
DXL
3.1.0
1
Amazon Linux 2 AMI  No No No
Amazon Linux AMI No No No
CentOS 7.x (64-bit only) Yes Yes Yes
CentOS 6.x (32-bit and 64-bit) Yes Yes Yes
Debian 9.x (32-bit and 64-bit) Yes No No
Debian 8.x, 7.x (32-bit and 64-bit) Yes Yes Yes
Fedora 28 (Server and Desktop) (64-bit) No No No
Fedora 29 (Server and Desktop) (64-bit) No No No
openSUSE Leap (42.2, 42.3, 15.0) (64-bit only) Yes Yes Yes
openSUSE Tumbleweed (32-bit and 64-bit) Yes Yes Yes
Oracle Enterprise Linux 7.x (64-bit only) Yes Yes Yes
Oracle Enterprise Linux 6.x (32-bit and 64-bit) Yes Yes Yes
Oracle Enterprise Linux 5.x (64-bit)
Oracle Enterprise Linux 5.x (32-bit)
No
No
No
No
No
No
McAfee Linux operating system 3.x, 2.2 (64-bit only) Yes Yes Yes
Red Hat Enterprise Linux 8.x (64-bit) No No No
Red Hat Enterprise Linux 7.x (64-bit) Yes Yes Yes
Red Hat Enterprise Linux 6.x (64-bit)
Red Hat Enterprise Linux 6.x (32-bit)
Yes Yes Yes
Red Hat Enterprise Linux 5.x (64-bit)
Red Hat Enterprise Linux 5.x (32-bit)
No
No
No
No
No
No
SUSE Linux Enterprise Desktop 15.x, 12.x, 11.x No No No
SUSE Linux Enterprise Server 15.x No No No
SUSE Linux Enterprise Server 12.x, 11.x Yes No No
Ubuntu 18.04.x LTS No No No
Ubuntu 16.04.x LTS, 14.04.x LTS Yes Yes Yes
1 DXL 3.1.x reaches EOL on April 10, 2019. See KB90487 for details.
   
 
Supported Hypervisors for the DXL 4.1.x - 5.0.x broker
 
Hypervisor Broker deployment method
Package Type .iso 1 .ova 1 Broker Install
Upgrade Package 2
VMware vSphere Yes Yes Yes
Hyper-V 12 Yes No Yes
Citrix XenServer 7.2.0 Yes No Yes
Oracle VM Server 3.4.4 3 No No Yes
Kernel-based Virtual Machines (KVM) 10.1.5.3 on CentOS 7.0 4 Yes Yes Yes
Nutanix Acropolis Hypervisor: 2019.02.11 Yes No Yes
 
1 Refers only to a broker running on the MLOS operating system.
2 Broker upgrade package only applies to CentOS, Red Hat, and MLOS.
Broker Install package applies to CentOS and Red Hat.
3 ISO deploy is not supported on Oracle VM server because of a known issue. See KB90521.
4 When deploying the broker .iso or .ova in KVM, set the Virtual Disk (Disk Bus) as SATA (typically in the Advanced Options).


Supported Hypervisors for the DXL 3.1.0 - 4.0.0 broker
 
Hypervisor Broker deployment method
Package Type .iso 1 .ova 1 Broker Install
Upgrade Package 2
VMware vSphere Yes Yes Yes
Hyper-V 12 No No Yes
Citrix XenServer 7.2.0 No No Yes
Oracle VM Server 3.4.4 No No Yes
Kernel-based Virtual Machines (KVM) 10.1.5.3 on CentOS 7.0 No No Yes
1 Broker .iso and .ova packages are MLOS only.
2 Broker upgrade package only applies to CentOS, Red Hat, and MLOS.
Broker install package applies to CentOS and Red Hat.

The DXL C++ client is supported on all Hypervisors.

 
Microsoft Windows Server supported operating systems with the DXL Broker
Operating System DXL
5.0.0
5.0.1
DXL
4.1.1
4.1.2
DXL
4.0.0
4.1.0
DXL
3.1.0
Windows Server 2019 (64-bit only) Yes No No No
Windows Server 2016 RS3 (64-bit only) Yes No No No
Windows Server 2016 (64-bit only) Yes No No No
Windows Server 2012 R2 (64-bit only) Yes No No No
Windows Server 2012 (64-bit only) Yes No No No
Windows Server 2012 Yes No No No
Windows Server 2008 with Service Pack 2 (64-bit only) Yes No No No
CentOS 7.x Yes Yes Yes Yes
CentOS 6.x Yes Yes Yes Yes
Red Hat Enterprise Linux 8.x Yes1 No No No
Red Hat Enterprise Linux 7.x Yes Yes Yes Yes
Red Hat Enterprise Linux 6.x Yes Yes Yes Yes
1 Red Hat Enterprise Linux 8.x is supported only with DXL 5.0.1 Hotfix 3 and later.

NOTE: The DXL Broker can be installed on the same system as the ePO Server, SuperAgents, or Agent Handlers.
 
DXL Versions ePO
5.10.0
ePO
5.9.x
ePO
5.3.x
ePO
5.1.x
(EOL)
DXL 4.1.0, 4.1.1, 4.1.2, 5.0.0, 5.0.1 Yes Yes 2 Yes 1 No
DXL 3.1.0–4.0.0 No Yes 2 Yes 1 Yes 1
DXL 2.0.0–3.0.0 No No Yes 1 Yes 1
1 Requires the following minimum versions of managed product extensions and packages to be checked in:
  • VirusScan Enterprise 8.8 Update 5
  • McAfee Agent 5.0
    • McAfee Agent 5.0 extension
2 The MA 5.0.4.104 extension is the minimum extension version supported in ePO 5.9.0. MA 5.0.4.104 is backward compatible with previous MA clients.

Rate this document

Beta Translate with

Select a desired language below to translate this page.

Glossary of Technical Terms


 Highlight Glossary Terms

Please take a moment to browse our Glossary of Technical Terms.